re = /([A-Za-z_]+)|\"[^".]+\"|([>,])/m
str = 'jsx_expression > "{", jsx_expression > ","
template_substitution > "${"
template_substitution > foo , bar
foo > bar > baz
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end