package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Za-z_]+)|\"[^".]+\"|([>,])`)
var str = `jsx_expression > "{", jsx_expression > ","
template_substitution > "${"
template_substitution > foo , bar
foo > bar > baz
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}