using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z_]+)|\""[^"".]+\""|([>,])";
string input = @"jsx_expression > ""{"", jsx_expression > "",""
template_substitution > ""${""
template_substitution > foo , bar
foo > bar > baz
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}