import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z_]+)|\\\"[^\".]+\\\"|([>,])";
final String string = "jsx_expression > \"{\", jsx_expression > \",\"\n"
+ "template_substitution > \"${\"\n"
+ "template_substitution > foo , bar\n"
+ "foo > bar > baz\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}