$re = '/([A-Za-z_]+)|\"[^".]+\"|([>,])/m';
$str = 'jsx_expression > "{", jsx_expression > ","
template_substitution > "${"
template_substitution > foo , bar
foo > bar > baz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);