import Foundation
let pattern = #"^([ ]*(?:[-]|[+])?[ ]*\d+(?:,\d+|))([ ]*(?:[+]|[-])[ ]*(?:\d+(?:,\d+|)[ ]*[*]?[ ]*|)i[ ]*|[ ]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1421
-124
-1245,
1234,
1235,002400
12435,000
-132435,0
+134235,014000
-1324,42 +i
345,4+ i*452,0250
+345-i452,00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)