use strict;
my $str = '1421
-124
-1245,
1234,
1235,002400
12435,000
-132435,0
+134235,014000
-1324,42 +i
345,4+ i*452,0250
+345-i452,00';
my $regex = qr/^([ ]*(?:[-]|[+])?[ ]*\d+(?:,\d+|))([ ]*(?:[+]|[-])[ ]*(?:\d+(?:,\d+|)[ ]*[*]?[ ]*|)i[ ]*|[ ]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}