const regex = /^([ ]*(?:[-]|[+])?[ ]*\d+(?:,\d+|))([ ]*(?:[+]|[-])[ ]*(?:\d+(?:,\d+|)[ ]*[*]?[ ]*|)i[ ]*|[ ]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([ ]*(?:[-]|[+])?[ ]*\\d+(?:,\\d+|))([ ]*(?:[+]|[-])[ ]*(?:\\d+(?:,\\d+|)[ ]*[*]?[ ]*|)i[ ]*|[ ]*)$', 'gm')
const str = `1421
-124
-1245,
1234,
1235,002400
12435,000
-132435,0
+134235,014000
-1324,42 +i
345,4+ i*452,0250
+345-i452,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}