import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([ ]*(?:[-]|[+])?[ ]*\\d+(?:,\\d+|))([ ]*(?:[+]|[-])[ ]*(?:\\d+(?:,\\d+|)[ ]*[*]?[ ]*|)i[ ]*|[ ]*)$";
final String string = "1421\n"
+ "-124\n"
+ "-1245,\n"
+ "1234,\n"
+ "1235,002400\n"
+ "12435,000\n"
+ "-132435,0\n"
+ "+134235,014000\n"
+ "-1324,42 +i\n"
+ "345,4+ i*452,0250\n"
+ "+345-i452,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}