using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([ ]*(?:[-]|[+])?[ ]*\d+(?:,\d+|))([ ]*(?:[+]|[-])[ ]*(?:\d+(?:,\d+|)[ ]*[*]?[ ]*|)i[ ]*|[ ]*)$";
string input = @"1421
-124
-1245,
1234,
1235,002400
12435,000
-132435,0
+134235,014000
-1324,42 +i
345,4+ i*452,0250
+345-i452,00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}