re = /^([ ]*(?:[-]|[+])?[ ]*\d+(?:,\d+|))([ ]*(?:[+]|[-])[ ]*(?:\d+(?:,\d+|)[ ]*[*]?[ ]*|)i[ ]*|[ ]*)$/m
str = '1421
-124
-1245,
1234,
1235,002400
12435,000
-132435,0
+134235,014000
-1324,42 +i
345,4+ i*452,0250
+345-i452,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end