import Foundation
let pattern = #"^(?<!\/dist\/)(.*)\/(.*?\.css)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
/internal/benefitlist/pmlweb.min.css
/internal/benefitlist
/dist/pmlweb.min.css
dist/pmlweb.min.css
/pmlweb.min.css
/dist/a.css
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/dist/$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)