re = /^(?<!\/dist\/)(.*)\/(.*?\.css)$/im
str = '/internal/benefitlist/pmlweb.min.css
/internal/benefitlist
/dist/pmlweb.min.css
dist/pmlweb.min.css
/pmlweb.min.css
/dist/a.css
'
subst = '/dist/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result