const regex = /^(?<!\/dist\/)(.*)\/(.*?\.css)$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<!\\\/dist\\\/)(.*)\\\/(.*?\\.css)$', 'gim')
const str = `/internal/benefitlist/pmlweb.min.css
/internal/benefitlist
/dist/pmlweb.min.css
dist/pmlweb.min.css
/pmlweb.min.css
/dist/a.css
`;
const subst = `/dist/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);