$re = '/^(?<!\/dist\/)(.*)\/(.*?\.css)$/im';
$str = '/internal/benefitlist/pmlweb.min.css
/internal/benefitlist
/dist/pmlweb.min.css
dist/pmlweb.min.css
/pmlweb.min.css
/dist/a.css
';
$subst = "/dist/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;