using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<!\/dist\/)(.*)\/(.*?\.css)$";
string substitution = @"/dist/$2";
string input = @"/internal/benefitlist/pmlweb.min.css
/internal/benefitlist
/dist/pmlweb.min.css
dist/pmlweb.min.css
/pmlweb.min.css
/dist/a.css
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}