import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<!\\/dist\\/)(.*)\\/(.*?\\.css)$";
final String string = "/internal/benefitlist/pmlweb.min.css\n"
+ "/internal/benefitlist\n"
+ "/dist/pmlweb.min.css\n"
+ "dist/pmlweb.min.css\n"
+ "/pmlweb.min.css\n"
+ "/dist/a.css\n";
final String subst = "/dist/$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}