// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(")?([^{:"]+)(")?(: )(")?([^,}"]+)(")?(, |}+)"#).unwrap();
let string = "{location: \"Tel Aviv\", party_size: 2, date_time: 2023-05-06:09:00:00Z}";
let substitution = "\"$2\"$4\"$6\"$8";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}