import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\")?([^\\{:\"]+)(\")?(: )(\")?([^,\\}\"]+)(\")?(, |\\}+)";
final String string = "{location: \"Tel Aviv\", party_size: 2, date_time: 2023-05-06:09:00:00Z}";
final String subst = "\"$2\"$4\"$6\"$8";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}