#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(")?([^{:"]+)(")?(: )(")?([^,}"]+)(")?(, |}+)"
Local $sString = "{location: "Tel Aviv", party_size: 2, date_time: 2023-05-06:09:00:00Z}"
Local $sSubst = ""$2"$4"$6"$8"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)