# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(")?([^{:"]+)(")?(: )(")?([^,}"]+)(")?(, |}+)/"$2"$4"$6"$8/g;t' <<< "{location: \"Tel Aviv\", party_size: 2, date_time: 2023-05-06:09:00:00Z}"