const regex = /(")?([^{:"]+)(")?(: )(")?([^,}"]+)(")?(, |}+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(")?([^{:"]+)(")?(: )(")?([^,}"]+)(")?(, |}+)', 'g')
const str = `{location: "Tel Aviv", party_size: 2, date_time: 2023-05-06:09:00:00Z}`;
const subst = `"$2"$4"$6"$8`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);