package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(")?([^{:"]+)(")?(: )(")?([^,}"]+)(")?(, |}+)`)
var str = `{location: "Tel Aviv", party_size: 2, date_time: 2023-05-06:09:00:00Z}`
var substitution = ""$2"$4"$6"$8"
fmt.Println(re.ReplaceAllString(str, substitution))
}