// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Expr").unwrap();
let string = "este es un ejemplo•de Expr donde podemos ver claramente
que, ésta•seleccion Expr, pero no me selecciona expr
¿por •que•me selecciona \"Expr\" pero no•me•selecciona• \"expr\" ?";
let substitution = "<<reemplazar>>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}