const regex = /Expr/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Expr', 'gm')
const str = `este es un ejemplo•de Expr donde podemos ver claramente
que, ésta•seleccion Expr, pero no me selecciona expr
¿por •que•me selecciona "Expr" pero no•me•selecciona• "expr" ?`;
const subst = `<<reemplazar>>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);