using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Expr";
string substitution = @"<<reemplazar>>";
string input = @"este es un ejemplo•de Expr donde podemos ver claramente
que, ésta•seleccion Expr, pero no me selecciona expr
¿por •que•me selecciona ""Expr"" pero no•me•selecciona• ""expr"" ?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}