import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Expr";
final String string = "este es un ejemplo•de Expr donde podemos ver claramente\n"
+ "que, ésta•seleccion Expr, pero no me selecciona expr\n\n"
+ "¿por •que•me selecciona \"Expr\" pero no•me•selecciona• \"expr\" ?";
final String subst = "<<reemplazar>>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}