package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Expr`)
var str = `este es un ejemplo•de Expr donde podemos ver claramente
que, ésta•seleccion Expr, pero no me selecciona expr
¿por •que•me selecciona "Expr" pero no•me•selecciona• "expr" ?`
var substitution = "<<reemplazar>>"
fmt.Println(re.ReplaceAllString(str, substitution))
}