import Foundation
let pattern = #"\\(ref){eq:(.*?)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\ref{eq:0And1Qubit} hjhg
\ref{eq:EulerForm}the state is measured, as it can be shown $|\rho e^{i\theta}|^2=\rho^2$ ($i$ is always the imaginary unit in this report). In other words, it is not possible to measure the global phase. The description of $\ket{q}$ can then be confined to $\alpha,\beta,\phi\in\mathbb{R}$, where $\phi$ is the relative phase $\phi=\theta_\beta-\theta_\alpha$.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\eqref{eq:$2}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)