# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\\(ref){eq:(.*?)}"
test_str = ("\\ref{eq:0And1Qubit} hjhg\n"
"\\ref{eq:EulerForm}the state is measured, as it can be shown $|\\rho e^{i\\theta}|^2=\\rho^2$ ($i$ is always the imaginary unit in this report). In other words, it is not possible to measure the global phase. The description of $\\ket{q}$ can then be confined to $\\alpha,\\beta,\\phi\\in\\mathbb{R}$, where $\\phi$ is the relative phase $\\phi=\\theta_\\beta-\\theta_\\alpha$.")
subst = "\\\\eqref{eq:$2}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.