import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\(ref)\\{eq:(.*?)\\}";
final String string = "\\ref{eq:0And1Qubit} hjhg\n"
+ "\\ref{eq:EulerForm}the state is measured, as it can be shown $|\\rho e^{i\\theta}|^2=\\rho^2$ ($i$ is always the imaginary unit in this report). In other words, it is not possible to measure the global phase. The description of $\\ket{q}$ can then be confined to $\\alpha,\\beta,\\phi\\in\\mathbb{R}$, where $\\phi$ is the relative phase $\\phi=\\theta_\\beta-\\theta_\\alpha$.";
final String subst = "\\\\eqref{eq:$2}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}