$re = '/\\\\(ref){eq:(.*?)}/m';
$str = '\\ref{eq:0And1Qubit} hjhg
\\ref{eq:EulerForm}the state is measured, as it can be shown $|\\rho e^{i\\theta}|^2=\\rho^2$ ($i$ is always the imaginary unit in this report). In other words, it is not possible to measure the global phase. The description of $\\ket{q}$ can then be confined to $\\alpha,\\beta,\\phi\\in\\mathbb{R}$, where $\\phi$ is the relative phase $\\phi=\\theta_\\beta-\\theta_\\alpha$.';
$subst = "\\eqref{eq:$2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;