using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\(ref){eq:(.*?)}";
string substitution = @"\\eqref{eq:$2}";
string input = @"\ref{eq:0And1Qubit} hjhg
\ref{eq:EulerForm}the state is measured, as it can be shown $|\rho e^{i\theta}|^2=\rho^2$ ($i$ is always the imaginary unit in this report). In other words, it is not possible to measure the global phase. The description of $\ket{q}$ can then be confined to $\alpha,\beta,\phi\in\mathbb{R}$, where $\phi$ is the relative phase $\phi=\theta_\beta-\theta_\alpha$.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}