// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^download\/(?P<doc>[^\/]+)[|\/]{0,1}(?P<mode>[\w]{0,})[|\/]{0,1}$").unwrap();
let string = "download/uuid_file.pdf/modeset1
download/uuid_file.pdf/modeset1/
download/uuid_file.pdf/
download/uuid_file.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}