package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^download\/(?P<doc>[^\/]+)[|\/]{0,1}(?P<mode>[\w]{0,})[|\/]{0,1}$`)
var str = `download/uuid_file.pdf/modeset1
download/uuid_file.pdf/modeset1/
download/uuid_file.pdf/
download/uuid_file.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}