#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^download\/(?P<doc>[^\/]+)[|\/]{0,1}(?P<mode>[\w]{0,})[|\/]{0,1}$"
Local $sString = "download/uuid_file.pdf/modeset1" & @CRLF & _
"download/uuid_file.pdf/modeset1/" & @CRLF & _
"download/uuid_file.pdf/" & @CRLF & _
"download/uuid_file.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")