using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^download\/(?P<doc>[^\/]+)[|\/]{0,1}(?P<mode>[\w]{0,})[|\/]{0,1}$";
string input = @"download/uuid_file.pdf/modeset1
download/uuid_file.pdf/modeset1/
download/uuid_file.pdf/
download/uuid_file.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}