$re = '/^download\/(?P<doc>[^\/]+)[|\/]{0,1}(?P<mode>[\w]{0,})[|\/]{0,1}$/m';
$str = 'download/uuid_file.pdf/modeset1
download/uuid_file.pdf/modeset1/
download/uuid_file.pdf/
download/uuid_file.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);