import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^download\\/(?P<doc>[^\\/]+)[|\\/]{0,1}(?P<mode>[\\w]{0,})[|\\/]{0,1}$";
final String string = "download/uuid_file.pdf/modeset1\n"
+ "download/uuid_file.pdf/modeset1/\n"
+ "download/uuid_file.pdf/\n"
+ "download/uuid_file.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}