// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.(css|scss)$").unwrap();
let string = "# NEED
index.css
index.scss
# NOT NEED
index.module.css
index.module.scss
# NOT NEED TOO
index.js
index.ts";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}