import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(css|scss)$";
final String string = "# NEED\n"
+ "index.css\n"
+ "index.scss\n\n"
+ "# NOT NEED\n"
+ "index.module.css\n"
+ "index.module.scss\n\n"
+ "# NOT NEED TOO\n"
+ "index.js\n"
+ "index.ts";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}