re = /\.(css|scss)$/m
str = '# NEED
index.css
index.scss
# NOT NEED
index.module.css
index.module.scss
# NOT NEED TOO
index.js
index.ts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end