using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(css|scss)$";
string input = @"# NEED
index.css
index.scss
# NOT NEED
index.module.css
index.module.scss
# NOT NEED TOO
index.js
index.ts";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}