#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.(css|scss)$"
Local $sString = "# NEED" & @CRLF & _
"index.css" & @CRLF & _
"index.scss" & @CRLF & _
"" & @CRLF & _
"# NOT NEED" & @CRLF & _
"index.module.css" & @CRLF & _
"index.module.scss" & @CRLF & _
"" & @CRLF & _
"# NOT NEED TOO" & @CRLF & _
"index.js" & @CRLF & _
"index.ts"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")