package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.(css|scss)$`)
var str = `# NEED
index.css
index.scss
# NOT NEED
index.module.css
index.module.scss
# NOT NEED TOO
index.js
index.ts`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}