re = /^ *([\+\-]?) *(?>([0-9]+)[.,]?([0-9]*)|[.,]?([0-9]+)) *%? *$/
str = ' - 123.987 %'
subst = '$1$2.$3$4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result