$re = '/^ *([\+\-]?) *(?>([0-9]+)[.,]?([0-9]*)|[.,]?([0-9]+)) *%? *$/';
$str = ' - 123.987 %';
$subst = "$1$2.$3$4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;