using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ *([\+\-]?) *(?>([0-9]+)[.,]?([0-9]*)|[.,]?([0-9]+)) *%? *$";
string substitution = @"$1$2.$3$4";
string input = @" - 123.987 %";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}