const regex = new RegExp('^ *([\\+\\-]?) *(?>([0-9]+)[.,]?([0-9]*)|[.,]?([0-9]+)) *%? *$', '')
const str = ` - 123.987 %`;
const subst = `$1$2.$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);