use strict;
my $str = ' - 123.987 %';
my $regex = qr/^ *([\+\-]?) *(?>([0-9]+)[.,]?([0-9]*)|[.,]?([0-9]+)) *%? *$/p;
my $subst = '$1$2.$3$4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";